# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(25 Eur)$/Steam 25 Euro/gm;t' <<< "Apple Itunes 25 Euro Guthaben Prepaid De', 'Apple iTunes 25 Euro
25 Eur"