use strict;
my $str = 'Apple Itunes 25 Euro Guthaben Prepaid De\', \'Apple iTunes 25 Euro
25 Eur';
my $regex = qr/^(25 Eur)$/mp;
my $subst = 'Steam 25 Euro';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";