const regex = /^(25 Eur)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(25 Eur)$', 'gm')
const str = `Apple Itunes 25 Euro Guthaben Prepaid De', 'Apple iTunes 25 Euro
25 Eur`;
const subst = `Steam 25 Euro`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);