re = /^(25 Eur)$/m
str = 'Apple Itunes 25 Euro Guthaben Prepaid De\', \'Apple iTunes 25 Euro
25 Eur'
subst = 'Steam 25 Euro'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result