# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(half|quarter|third|\d+)|./\1/gm;t' <<< "here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego
heres another one with numbers 132 1244 5950 303 2022 and one and a half
plz help me with code i am struggling"