package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(half|quarter|third|\d+)|.`)
var str = `here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego
heres another one with numbers 132 1244 5950 303 2022 and one and a half
plz help me with code i am struggling`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}