use strict;
my $str = 'here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego
heres another one with numbers 132 1244 5950 303 2022 and one and a half
plz help me with code i am struggling';
my $regex = qr/(half|quarter|third|\d+)|./mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";