# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(half|quarter|third|\d+)|."
test_str = ("here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego\n"
"heres another one with numbers 132 1244 5950 303 2022 and one and a half\n"
"plz help me with code i am struggling")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.