import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(half|quarter|third|\\d+)|.";
final String string = "here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego\n"
+ "heres another one with numbers 132 1244 5950 303 2022 and one and a half\n"
+ "plz help me with code i am struggling";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}