// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(half|quarter|third|\d+)|.").unwrap();
let string = "here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego
heres another one with numbers 132 1244 5950 303 2022 and one and a half
plz help me with code i am struggling";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}