using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(half|quarter|third|\d+)|.";
string substitution = @"\1";
string input = @"here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego
heres another one with numbers 132 1244 5950 303 2022 and one and a half
plz help me with code i am struggling";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}