re = /(half|quarter|third|\d+)|./m
str = 'here is some text with stuff inside that i dont need but also some that i do, here is a word half and quarter also 99 is too old for lego
heres another one with numbers 132 1244 5950 303 2022 and one and a half
plz help me with code i am struggling'
subst = '\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result