#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^_?[^_\n]+(?:_[^_\n]+)*(?:__\d+)?$"
Local $sString = "foo_bar__2" & @CRLF & _
"foo" & @CRLF & _
"foo--$%^##" & @CRLF & _
"$%^#" & @CRLF & _
"foo__42" & @CRLF & _
"_foo_bar__32" & @CRLF & _
"foo_" & @CRLF & _
"f__o__2" & @CRLF & _
"_" & @CRLF & _
"foo___2" & @CRLF & _
"foo__xzy"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")