import re
regex = re.compile(r"^_?[^_\n]+(?:_[^_\n]+)*(?:__\d+)?$", flags=re.MULTILINE)
test_str = ("foo_bar__2\n"
"foo\n"
"foo--$%^##\n"
"$%^#\n"
"foo__42\n"
"_foo_bar__32\n"
"foo_\n"
"f__o__2\n"
"_\n"
"foo___2\n"
"foo__xzy")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")