import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^_?[^_\\n]+(?:_[^_\\n]+)*(?:__\\d+)?$";
final String string = "foo_bar__2\n"
+ "foo\n"
+ "foo--$%^##\n"
+ "$%^#\n"
+ "foo__42\n"
+ "_foo_bar__32\n"
+ "foo_\n"
+ "f__o__2\n"
+ "_\n"
+ "foo___2\n"
+ "foo__xzy";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}