const regex = new RegExp('^_?[^_\\n]+(?:_[^_\\n]+)*(?:__\\d+)?$', 'gm')
const str = `foo_bar__2
foo
foo--\$%^##
\$%^#
foo__42
_foo_bar__32
foo_
f__o__2
_
foo___2
foo__xzy`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}