use strict;
my $str = 'foo_bar__2
foo
foo--$%^##
$%^#
foo__42
_foo_bar__32
foo_
f__o__2
_
foo___2
foo__xzy';
my $regex = qr/^_?[^_\n]+(?:_[^_\n]+)*(?:__\d+)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}