re = /^_?[^_\n]+(?:_[^_\n]+)*(?:__\d+)?$/m
str = 'foo_bar__2
foo
foo--$%^##
$%^#
foo__42
_foo_bar__32
foo_
f__o__2
_
foo___2
foo__xzy'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end