package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^_?[^_\n]+(?:_[^_\n]+)*(?:__\d+)?$`)
var str = `foo_bar__2
foo
foo--$%^##
$%^#
foo__42
_foo_bar__32
foo_
f__o__2
_
foo___2
foo__xzy`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}