using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^_?[^_\n]+(?:_[^_\n]+)*(?:__\d+)?$";
string input = @"foo_bar__2
foo
foo--$%^##
$%^#
foo__42
_foo_bar__32
foo_
f__o__2
_
foo___2
foo__xzy";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}