# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<label .*?>(.*?)<\\/label>/$1/g;t' <<< "<label class=\"s-nav right\" for=\"s-22\">simply</label>
<label class=\"s-nav left\" for=\"s-21\">dummy</label>
<label class=\"s-nav right\" for=\"s-23\">text</label>
<label class=\"s-nav left\" for=\"s-22\">of the printing</label>
<label class=\"s-nav right\" for=\"s-24\">and typesetting</label>
<label class=\"s-nav left\" for=\"s-23\">industry</label>
<label class=\"s-nav right\" for=\"s-25\">Lorem Ipsum</label>
<label class=\"s-nav left\" for=\"s-24\">Ipsum</label>"