package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<label .*?>(.*?)<\/label>`)
var str = `<label class="s-nav right" for="s-22">simply</label>
<label class="s-nav left" for="s-21">dummy</label>
<label class="s-nav right" for="s-23">text</label>
<label class="s-nav left" for="s-22">of the printing</label>
<label class="s-nav right" for="s-24">and typesetting</label>
<label class="s-nav left" for="s-23">industry</label>
<label class="s-nav right" for="s-25">Lorem Ipsum</label>
<label class="s-nav left" for="s-24">Ipsum</label>`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}