using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<label .*?>(.*?)<\/label>";
string substitution = @"$1";
string input = @"<label class=""s-nav right"" for=""s-22"">simply</label>
<label class=""s-nav left"" for=""s-21"">dummy</label>
<label class=""s-nav right"" for=""s-23"">text</label>
<label class=""s-nav left"" for=""s-22"">of the printing</label>
<label class=""s-nav right"" for=""s-24"">and typesetting</label>
<label class=""s-nav left"" for=""s-23"">industry</label>
<label class=""s-nav right"" for=""s-25"">Lorem Ipsum</label>
<label class=""s-nav left"" for=""s-24"">Ipsum</label>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}