// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<label .*?>(.*?)<\/label>").unwrap();
let string = "<label class=\"s-nav right\" for=\"s-22\">simply</label>
<label class=\"s-nav left\" for=\"s-21\">dummy</label>
<label class=\"s-nav right\" for=\"s-23\">text</label>
<label class=\"s-nav left\" for=\"s-22\">of the printing</label>
<label class=\"s-nav right\" for=\"s-24\">and typesetting</label>
<label class=\"s-nav left\" for=\"s-23\">industry</label>
<label class=\"s-nav right\" for=\"s-25\">Lorem Ipsum</label>
<label class=\"s-nav left\" for=\"s-24\">Ipsum</label>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}