const regex = /<label .*?>(.*?)<\/label>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<label .*?>(.*?)<\\\/label>', 'g')
const str = `<label class="s-nav right" for="s-22">simply</label>
<label class="s-nav left" for="s-21">dummy</label>
<label class="s-nav right" for="s-23">text</label>
<label class="s-nav left" for="s-22">of the printing</label>
<label class="s-nav right" for="s-24">and typesetting</label>
<label class="s-nav left" for="s-23">industry</label>
<label class="s-nav right" for="s-25">Lorem Ipsum</label>
<label class="s-nav left" for="s-24">Ipsum</label>`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);