# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\d{3})\B/$1./gm;t' <<< "0987654321
987654321
87654321
7654321
654321
54321
4321
321
21
1
"