package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d{3})\B`)
var str = `0987654321
987654321
87654321
7654321
654321
54321
4321
321
21
1
`
var substitution = "$1."
fmt.Println(re.ReplaceAllString(str, substitution))
}