re = /(\d{3})\B/m
str = '0987654321
987654321
87654321
7654321
654321
54321
4321
321
21
1
'
subst = '$1.'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result