import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{3})\\B";
final String string = "0987654321\n"
+ "987654321\n"
+ "87654321\n"
+ "7654321\n"
+ "654321\n"
+ "54321\n"
+ "4321\n"
+ "321\n"
+ "21\n"
+ "1\n";
final String subst = "$1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}