#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\d{3})\B"
Local $sString = "0987654321" & @CRLF & _
"987654321" & @CRLF & _
"87654321" & @CRLF & _
"7654321" & @CRLF & _
"654321" & @CRLF & _
"54321" & @CRLF & _
"4321" & @CRLF & _
"321" & @CRLF & _
"21" & @CRLF & _
"1" & @CRLF & _
""
Local $sSubst = "$1."
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)