use strict;
my $str = '0987654321
987654321
87654321
7654321
654321
54321
4321
321
21
1
';
my $regex = qr/(\d{3})\B/mp;
my $subst = '$1.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";