# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\d{3})\B"
test_str = ("0987654321\n"
"987654321\n"
"87654321\n"
"7654321\n"
"654321\n"
"54321\n"
"4321\n"
"321\n"
"21\n"
"1\n")
subst = "$1."
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.