const regex = /(\d{3})\B/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d{3})\\B', 'gm')
const str = `0987654321
987654321
87654321
7654321
654321
54321
4321
321
21
1
`;
const subst = `$1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);