// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d{3})\B").unwrap();
let string = "0987654321
987654321
87654321
7654321
654321
54321
4321
321
21
1
";
let substitution = "$1.";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}