#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((\/|\\|\/\/|https?:\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\[\]]+)+\.[a-z]+$"
Local $sString = "/some/path-to-fie/resource.zip" & @CRLF & _
"google.com/some/path-to-fie/resource.zip" & @CRLF & _
"https://google.com/some/path-to-fie/10000/3213/resource.ext" & @CRLF & _
"http://google.com/some/path-to-fie/resource.doc" & @CRLF & _
"://google.com/some/path-to-fie/resource.png" & @CRLF & _
"./some/path-to-fie/resource.zip" & @CRLF & _
"/resource.png" & @CRLF & _
"" & @CRLF & _
"// You can show origina post on albertcolom.com/blog"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")