const regex = /^((\/|\\|\/\/|https?:\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\[\]]+)+\.[a-z]+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((\\\/|\\\\|\\\/\\\/|https?:\\\\\\\\|https?:\\\/\\\/)[a-z0-9_@\\-^!#$%&+={}.\\\/\\\\\\[\\]]+)+\\.[a-z]+$', 'gmi')
const str = `/some/path-to-fie/resource.zip
google.com/some/path-to-fie/resource.zip
https://google.com/some/path-to-fie/10000/3213/resource.ext
http://google.com/some/path-to-fie/resource.doc
://google.com/some/path-to-fie/resource.png
./some/path-to-fie/resource.zip
/resource.png
// You can show origina post on albertcolom.com/blog`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}