// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^((\/|\\|\/\/|https?:\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\[\]]+)+\.[a-z]+$").unwrap();
let string = "/some/path-to-fie/resource.zip
google.com/some/path-to-fie/resource.zip
https://google.com/some/path-to-fie/10000/3213/resource.ext
http://google.com/some/path-to-fie/resource.doc
://google.com/some/path-to-fie/resource.png
./some/path-to-fie/resource.zip
/resource.png
// You can show origina post on albertcolom.com/blog";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}