use strict;
my $str = '/some/path-to-fie/resource.zip
google.com/some/path-to-fie/resource.zip
https://google.com/some/path-to-fie/10000/3213/resource.ext
http://google.com/some/path-to-fie/resource.doc
://google.com/some/path-to-fie/resource.png
./some/path-to-fie/resource.zip
/resource.png
// You can show origina post on albertcolom.com/blog';
my $regex = qr/^((\/|\\|\/\/|https?:\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\[\]]+)+\.[a-z]+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}