import Foundation
let pattern = ##"^((\/|\\|\/\/|https?:\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\[\]]+)+\.[a-z]+$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
/some/path-to-fie/resource.zip
google.com/some/path-to-fie/resource.zip
https://google.com/some/path-to-fie/10000/3213/resource.ext
http://google.com/some/path-to-fie/resource.doc
://google.com/some/path-to-fie/resource.png
./some/path-to-fie/resource.zip
/resource.png
// You can show origina post on albertcolom.com/blog
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)