# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((\/|\\|\/\/|https?:\\\\|https?:\/\/)[a-z0-9_@\-^!#$%&+={}.\/\\\[\]]+)+\.[a-z]+$"
test_str = ("/some/path-to-fie/resource.zip\n"
"google.com/some/path-to-fie/resource.zip\n"
"https://google.com/some/path-to-fie/10000/3213/resource.ext\n"
"http://google.com/some/path-to-fie/resource.doc\n"
"://google.com/some/path-to-fie/resource.png\n"
"./some/path-to-fie/resource.zip\n"
"/resource.png\n\n"
"// You can show origina post on albertcolom.com/blog")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.