import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((\\/|\\\\|\\/\\/|https?:\\\\\\\\|https?:\\/\\/)[a-z0-9_@\\-^!#$%&+=\\{\\}.\\/\\\\\\[\\]]+)+\\.[a-z]+$";
final String string = "/some/path-to-fie/resource.zip\n"
+ "google.com/some/path-to-fie/resource.zip\n"
+ "https://google.com/some/path-to-fie/10000/3213/resource.ext\n"
+ "http://google.com/some/path-to-fie/resource.doc\n"
+ "://google.com/some/path-to-fie/resource.png\n"
+ "./some/path-to-fie/resource.zip\n"
+ "/resource.png\n\n"
+ "// You can show origina post on albertcolom.com/blog";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}