# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(>=|<=|'[^']*(?:''[^']*)*')|=/$1/g;t' <<< "select * from where item1=abcd and price>=20 and item1 = abc and title='strings=evil''bugs' and id=-197"