import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(>=|<=|'[^']*(?:''[^']*)*')|=";
final String string = "select * from where item1=abcd and price>=20 and item1 = abc and title='strings=evil''bugs' and id=-197";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}