use strict;
my $str = 'select * from where item1=abcd and price>=20 and item1 = abc and title=\'strings=evil\'\'bugs\' and id=-197';
my $regex = qr/(>=|<=|'[^']*(?:''[^']*)*')|=/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";