using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(>=|<=|'[^']*(?:''[^']*)*')|=";
string substitution = @"$1";
string input = @"select * from where item1=abcd and price>=20 and item1 = abc and title='strings=evil''bugs' and id=-197";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}