$re = '/(>=|<=|\'[^\']*(?:\'\'[^\']*)*\')|=/';
$str = 'select * from where item1=abcd and price>=20 and item1 = abc and title=\'strings=evil\'\'bugs\' and id=-197';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;