import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\r\\n\\t]+\\K\\t([^\\r\\n\\t]+)\\t([^\\r\\n\\t]+)$";
final String string = "AAAA BBBBBBBBBBBBBBB CCCC";
final String subst = "_$2 $1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}