re = /^[^\r\n\t]+\K\t([^\r\n\t]+)\t([^\r\n\t]+)$/m
str = 'AAAA BBBBBBBBBBBBBBB CCCC'
subst = '_$2 $1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result