use strict;
my $str = 'AAAA BBBBBBBBBBBBBBB CCCC';
my $regex = qr/^[^\r\n\t]+\K\t([^\r\n\t]+)\t([^\r\n\t]+)$/mp;
my $subst = '_$2 $1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";