import Foundation
let pattern = #"^[^\r\n\t]+\K\t([^\r\n\t]+)\t([^\r\n\t]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"AAAA BBBBBBBBBBBBBBB CCCC"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_$2 $1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)